Sehr langsamer Start von DOpus.

Aktuelle Version: 12.30 (21.11.2022)
Alles zum Thema Directory Opus
Antworten
THambrecht
Beiträge: 3
Registriert: 27. Sep 2022 20:33
Betriebssystem: Windows 10 Home 64bit
DOpus Version: 12.29
Edition: Pro

Sehr langsamer Start von DOpus.

Beitrag von THambrecht »

Jedesmal wenn ich DOpus starte, dauert es bis zu zwei Minuten bis links die (Netz-)Laufwerke aufgebaut werden.
So kann ich einen Kaffee kochen, bis das benötigte Laufwerk angezeigt wird.
Aktuell: V12.29 (Windows 11 Pro x64 21H2)
Das Problem ist uns seit vielen Jahren bekannt - wird jetzt aber durch unsere Strom-Spar-Aktion sehr quälend.

Hintergrund: Wir haben sehr viele NAS-Laufwerke (Synology), von denen einige nur zu bestimmten Uhrzeiten oder auf Bedarf eingeschaltet werden (Strom sparen). Ebenso Netzlaufwerke, wo die PCs nicht immer eingeschaltet sind. Diese sind aber dauerhaft als Netzlaufwerke verbunden und werden auch täglich benötigt.
Diese (bis 5 inaktiven Verbindungen) bremsen DOpus aber unglaublich beim Starten aus. So quält sich DOpus bei jedem Fenster-Aufruf mit jedem einzelnen (inaktiven) Netzlaufwerk ab.
Im Vergleich dazu startet der einfache Windows Explorer binnen einer Sekunde und ignoriert, dass Netzlaufwerke fehlen.

Wir suchen seit längerer Zeit, ob es einen Schalter / Option gibt, damit DOPus nicht jedes einzelne Netzlaufwerk sehr lange prüft - sondern erst verbindet, wenn man das Laufwerk anklickt. Der Windows-Explorer zumindest kann und macht das sehr vorbildlich.
Freue mich über jeden Rat.
Benutzeravatar
Nobmen
Boardbetreuer
Beiträge: 102
Registriert: 15. Okt 2021 18:43
Betriebssystem: Windows 10 Pro 64bit
DOpus Version: 12.xx + Betas
Edition: Pro

Re: Sehr langsamer Start von DOpus.

Beitrag von Nobmen »

werden:
die nas über laufwerksbuchstaben aufgrufen. (da gibt es hin und wieder ein problem das seit 2015 von windows verursacht wird)
vordefinierte layouts/tabs verwendet wo auf dieses verbindungen verwiesen werden. (diese werden meist im hintergrund eingelesen)

versuche daher die option für das laden der betreffenden abzuändern
(normal zu tab oder verhindern)
laden.jpg
nachfrage:
ging die auswahl windows 11 im profil nicht?
THambrecht
Beiträge: 3
Registriert: 27. Sep 2022 20:33
Betriebssystem: Windows 10 Home 64bit
DOpus Version: 12.29
Edition: Pro

Re: Sehr langsamer Start von DOpus.

Beitrag von THambrecht »

Haben Sie vielen Dank.
Wir haben die Parameter für das automatische Laden ausgiebig getestet.
Leider ohne jeden Erfolg. Es scheint so, als ob die Einstellungen gar nicht berücksichtigt werden.
Auch mit "Laden verhindern" oder "Bei Tab-Aktivierung laden" gibt es keinen zeitlichen Unterschied bis auf der linken Seite die Laufwerke angezeigt werden.
Wobei dieses endlose Warten nur ausgeschaltete NAS-Laufwerke (Synology) betrifft. Netzlaufwerke ausgeschalteter Rechner werden sofort übersprungen.

Im schlimmsten Fall benötigt DOpus 2 Minuten zum Anzeigen des letzten Laufwerks - egal welche Einstellungen man hier vornimmt.
In der Praxis sieht das so aus, dass beim Start alle Laufwerksbuchstaben bis zum ersten nicht verbunden NAS-Laufwerk angezeigt werden. Dann dauert es 2 Minuten, bis plötzlich alle restlichen Laufwerke auf einmal eingeblendet werden. Das war so unter Win10, ebenso unter Win11.
(Leider können wir hier nicht mit UNC-Pfaden arbeiten, da unsere Programme damit nicht arbeiten wollen)
Benutzeravatar
Nobmen
Boardbetreuer
Beiträge: 102
Registriert: 15. Okt 2021 18:43
Betriebssystem: Windows 10 Pro 64bit
DOpus Version: 12.xx + Betas
Edition: Pro

Re: Sehr langsamer Start von DOpus.

Beitrag von Nobmen »

der bug mit den buchstaben ist bekannt und trat meistens auf wenn:
windows 10 älter als 21h1 (alles vor 05.2021) genutzt wird.
windows 11 (vielleicht mit aktueller nutzbar!) kann nicht geprüft werden da produktiv derzeit nicht einsetzbar (zuviele probleme)
älteres synology dsm als 6.2.4 (vor 03.2021)
könnte mit der 7.1.x beseitigt worden sein, kann das mit den buchstaben nicht prüfen da umgestellt, da gab es erneut 04.2022 änderungen
der neue windows browser chromium (ab 04.2021) als upgrade über den alten edge installiert. (engine wechsel)
THambrecht
Beiträge: 3
Registriert: 27. Sep 2022 20:33
Betriebssystem: Windows 10 Home 64bit
DOpus Version: 12.29
Edition: Pro

Re: Sehr langsamer Start von DOpus.

Beitrag von THambrecht »

Vielen Dank.
Die Synology DSM spielt aber keine Rolle, wenn die NAS physikalisch gerade aus-geschalten und nicht am Strom ist.
Streng genommen prüft DOpus eine tote Netzwerkverbindung zu einem unbekannten (gerade ausgeschalteten) Gerät.

Dennoch kann man programmier-technisch problemlos - und auch mit "net use" - innerhalb eines Bruchteils einer Sekunde die vorhandenen Netzverkverbindungen erfassen.
Würde man dieses Ergebnis einfach schonmal binnen einer halben Sekunde links darstellen, hätte man das Thema programmiertechnisch bereits gelöst. Dann wären alle N etz-Laufwerke sofort sichtbar, wenn auch noch nicht verbunden.
Selbst mit meinem uralten Visual Basic 6 erhalte ich die Netzlaufwerke binner einer zehntel-Sekunde.

Auch unsere AudioProgramme im Studio listen sofort die toten (gerade ausgeschalteten) Verbindungen "sofort".
Jedes Programm kann das.
Es wäre daher kinderleicht den seit etlichen Jahren bestehenden Fehler endlich einmal auszumerzen - statt diesen auf Windows oder Synology zu schieben.
Dazu muss der Programmierer nur mal 3 Verbindugen zu dem selben Netzwerkgerät nacheinander aufbauen und das Gerät wieder abziehen. Dann ärgert sich der Programmierer so über die Verzögerungen beim ProgrammStart, dass er sich dem Thema widmet.
Antworten