Seite 1 von 1

Suche mit Filter funktioniert nicht wie beschrieben

Verfasst: 23. Mär 2022 16:02
von holec
Hallo Zusammen

Ich möchte mir eine Suche mit verschiedenen Filtern zusammen stellen. In der Hilfe ist das so beschrieben, funktioniert aber nicht.
Bild_2022-03-23_155937.png
Diese Suche findet nur BMP Dateien, die größer sind als 10 MB, keine JPG.

Auch wenn ich rumprobiere, ich finde keinen Weg. In der einfachen Suche geht es, aber die kann ich nicht abspeichern :?:

Hat vielleicht jemand eine Idee? Danke!

Viele Grüße
holec

Re: Suche mit Filter funktioniert nicht wie beschrieben

Verfasst: 23. Mär 2022 17:11
von xbprm
Du willst offenbar (bmp && >10MB) || (jpg && >10 MB)

Die beiden Einzelbedinungen müssen per SubClause und dem "oder / ||" verbunden werden.
Clipboard Image.png
Mit ein bißchen Boolescher Algebra kann man deinen Ausdruck auch noch vereinefachen, zu

(bmp || jpg) && >10MB

Re: Suche mit Filter funktioniert nicht wie beschrieben

Verfasst: 24. Mär 2022 05:37
von Kundal
Versuch's mal damit:
Suche.jpg
Suche.jpg (42.64 KiB) 1706 mal betrachtet

Re: Suche mit Filter funktioniert nicht wie beschrieben

Verfasst: 25. Mär 2022 17:21
von josinoro
Hallo Kundal,

da ist dir ein Denkfehler unterlaufen. Um die Unterbedingung kommst du nicht herum.

Filter mit Unterbedingung.png
Filter mit Unterbedingung.png (11.11 KiB) 1688 mal betrachtet

Gruß

jo

Re: Suche mit Filter funktioniert nicht wie beschrieben

Verfasst: 26. Mär 2022 09:50
von Kundal
Hallo Josinoro, danke für die Korrektur. Du hast natürlich recht. Meins war Pfusch.